Talk:Baseband Commands

From The iPhone Wiki
Jump to: navigation, search

i bought an iphone from 2weeks with baseband 02.30.03 and bootlooder 6.2 and i need to unlock it to work with vodafone sim card need you'r help plz find me a sulution to unlock or downgrade my baseband so i can use yellowsn0w --The preceding unsigned comment was added by Na7la (talk) 15:57, April 16, 2009 (UTC). Please consult this page for more info on how to sign pages, and how to fix this.

I am having trouble figuring out how to run these commands on my iPhone 4. I mean minicom does not work. I saved and all but it wont let me see what command im typing and it says "offline" in the bottom. --The preceding unsigned comment was added by Grisolp (talk) 22:25, April 5, 2011 (UTC). Please consult this page for more info on how to sign pages, and how to fix this.

You have to remember, minicom hasn't been updated in a while. It's probably not going to work very well with iOS 4+, and pretty much any device after the iPhone 3G... also, sign your talk page comments :) --rdqronos 06:22, 23 July 2011 (MDT)

Working on the iPhone 4?

Well, I tried tty.debug, dlci.baseband.blablabla... amd it didn't seem to work very well. Are there new releases of minicom? Or the source of it? --XiiiX 17:09, 14 August 2011 (MDT)

Minicom is an open source project: [1] --pjakuszew 12:45, 15 August 2011 (MDT)
The days of tty.baseband are gone (1.x?). tty.debug does not require CommCenter to be shut down, but you have to spam AT[enter] until you get a reply and then issue your command hoping the connection doesn't fail as CommCenter is using the BB pretty much all the time making you unable to connect. Also, the OFFLINE message is normal. --Ryccardo 05:37, 16 August 2011 (MDT)
Would shutting down CommCenter help though? Like honestly, if it's that much of an issue, I'll run the command to kill it... Also, if I did kill CC, would I have to spam AT or would one typing of AT do it? --rdqronos 17:00, 16 August 2011 (MDT)
According to my experience in 3.x, shutting down CommCenter barely helps yet it's pretty much a requirement. Remember that shutting it down remover Wi-Fi until a reboot, so you have to permanently disable it (launchctl unload -w /System…), reboot until you can't get signal as per the status bar + get the non-visual voicemail indicator (empty badge over Phone icon), try your luck then enable CCenter with launchctl load -w /System…. --Ryccardo 16:50, 18 August 2011 (MDT)

One way around this is to install signal iphone app found in cydia:

"...Signal was designed for iOS 4, and contacts /dev/tty.debug in a iOS 4 compatible way, it does this to receive baseband information, one of them being, the exact measurement in dBm. This opens the port to /dev/tty.debug..." (

I can confirm this works.--JackR1 07:44, 23 September 2011 (MDT)

Working on the iPhone 5

I have Minicom set to connect to tty.debug connects* (if I turn off CommCenter using launchctl unload /System/Library/LaunchDaemons/, but it doesn't display anything. I've tried spamming AT with no success. I tested tty.wlan-debug to see if anything gets displayed, and it does. Anyways, here is a dump of my /dev:

aes_0 klog random ttyp9
bpf0 null rdisk0 ttypa
bpf1 pf rdisk0s1 ttypb
bpf2 pfm rdisk0s1s1 ttypc
bpf3 ptmx rdisk0s1s2 ttypd
btpoweroff ptyp0 tty ttype
btwake ptyp1 tty.bluetooth ttypf
console ptyp2 tty.debug ttys000
cu.bluetooth ptyp3 tty.debug-console uart.bluetooth
cu.debug ptyp4 tty.gas-gauge uart.debug
cu.debug-console ptyp5 tty.iap uart.debug-console
cu.gas-gauge ptyp6 tty.wlan-debug uart.gas-gauge
cu.iap ptyp7 ttyp0 uart.iap
cu.wlan-debug ptyp8 ttyp1 uart.wlan-debug
disk0 ptyp9 ttyp2 urandom
disk0s1 ptypa ttyp3 vn0
disk0s1s1 ptypb ttyp4 vn1
disk0s1s2 ptypc ttyp5 zero
fsevents ptypd ttyp6
io8log ptype ttyp7
io8logmt ptypf ttyp8

And ideas? I don't know what else to try. --Blue Skies (talk) 00:37, 8 February 2013 (UTC)

I have no experience with the baseband, but since the 4S there are no more AT commands afaik. The interface has changed completely. That's why planetbeing's Signal app no longer works. The new baseband chips use a different operating system and communication protocol. --http (talk) 08:08, 8 February 2013 (UTC)