Talk:Recovery Mode (Protocols)

From The iPhone Wiki
Jump to: navigation, search

I got iRecovery to connect to DFU, as the output said that it connected, but iRecovery also spit out "error claiming interface." any way to that? --rdqronos 14:31, 20 January 2012 (MST)

Are you trying to start a shell in DFU mode? This is impossible until you send an iBSS/iBEC/iBoot payload to the device... --pjakuszew 04:59, 21 January 2012 (MST)

Yup, I am. So, where would one get one of these fabled payloads? --rdqronos 08:34, 21 January 2012 (MST)

Get a pwn'd iBSS, upload it, then jump to it. --Squiffypwn 10:21, 21 January 2012 (CST)
So I'm guessing it wouldn't work on the 4S, seeing as a pwn'd anything above userland requires a bootrom exploit. --rdqronos 12:21, 21 January 2012 (MST)
These files are in every IPSW file, in Firmware/dfu/ folder, if you need them. Apple stopped including advanced commands in RELEASE-type iBoots since iOS 4.0, so these files aren't very useful now. --pjakuszew 13:29, 21 January 2012 (MST)
in iboot, but what about DFU mode? Or are they the exact same thing in terms of commands? --rdqronos 15:38, 21 January 2012 (MST)
BootROM does not have any commands implemented. It doesn't even have a shell that allows you to enter them. --pjakuszew 16:29, 21 January 2012 (MST)

I tried sending a command using the way described in the article, but I get -9 error from LibUSB. Of course, I did some initialization like setting configuration, claiming interface, all with success. What could be the problem? --Rzhikharevich (talk) 12:37, 21 March 2015 (UTC)

Perhaps you didn't use sudo to run it? Also, do you have the LIBUSB_DEBUG environment variable set for additional logging?--Awesomebing1 (talk) 18:35, 22 March 2015 (UTC)
I tried sudo, but it didn't work:
MacBook-Pro-Roman:libipwn roman$ sudo tools/irec-shell
libusbx: warning [darwin_cache_device_descriptor] could not retrieve device descriptor 05ac:8510: device not responding. skipping device
libusbx: warning [darwin_cache_device_descriptor] could not retrieve device descriptor 05ac:8286: pipe is stalled. skipping device
> reboot
debug: -9
--Rzhikharevich (talk) 13:50, 23 March 2015 (UTC)