From The iPhone Wiki
Jump to: navigation, search

Compilation notes


If anyone is trying to compile this using MinGW on Windows, you'll run into some linking problems with libcrypto. After searching around for awhile, I found that the problem can be solved by adding -lgdi32 to your linker flags.

I just needed the -lgdi32 What crap that a crypto lib linked to a graphics library

I don't know, it's screwy. I think a lot of OpenSSL is actually hacky on Windows (after reading the posts with corrections for this problem, it seems like their talking about some kind of pre-alpha program that barely works on anything besides Linux). Also, I see that compiling works with just gdi, so I removed it from my initial suggestion. Must have had ws2_32 first or something..

Mac compiling

Must have a recent copy of openssl installed. if you don't do this.

  • download and extract openssl [1]
  • run './config' and then 'make' to build the lib.
  • copy genpass.c into the openssl directory
  • compile with 'gcc genpass.c libcrypto.a -o genpass -I./include/'

plz correct me if I'm wrong, as I'm no mac expert --posixninja 21:52, 6 April 2009 (UTC)

Linux compiling

What do you expect? Works fine with just -lcrypto.

How to use?

Well, I tried to get the key for beta 2 for the 3g, I never could. I asked on #iPhone and they told me that. Platform is s5l8***x (s5l8900x) for the iPhones and ipt1g. Ramdisk is the path to a MOUNTED (decrypted) ramdisk file (not mount path). They didn't know wether it was the restore or update or both ramdisk. Main is the path to the big dmg file (the rootfs > 100 mb). Well this didn't work as I got different keys. Please correct what is wrong in the above. --dranfi

It shouldn't matter which ramdisk you use, however, you cannot use GenPass to extract correct keys from anything >b2 without decompressing the ramdisk first. Apparently, this is a Snow Leopard only feature for now. You could also (in theory) compile GenPass on your device and use iPhone OS' tools to mount the ramdisk (since they must know how to understand them), although I haven't gotten around to try this yet.
The compression is affecting beta 3 at this point or beta 1 and 2?
And, since I have snow leopard beta, how do you decompres it under snow leopard? And is this a new feature of snow leopard (in a recent build or from the begening, just that at the moment I have a slow connection making it hard to upgrade snow leopard)?
This compression affects betas 2 & 3, but not beta 1. And unfortunately I do not know how to decompress it under any system :( --Cool name 01:12, 16 April 2009 (UTC)
I assume that simply mounting a decrypted ramdisk under Snow Leopard would decompress it. --James 01:42, 16 April 2009 (UTC)