Difference between revisions of "N1ghtshade"

From The iPhone Wiki
Jump to: navigation, search
m (new versions)
m (fix infobox date)
 
Line 9: Line 9:
 
| developer = synackuk
 
| developer = synackuk
 
| released = beta 1 / {{start date and age|2019|12|07}}
 
| released = beta 1 / {{start date and age|2019|12|07}}
| latest release version = beta 6
+
| latest release version = beta 9
 
| latest release date = {{start date and age|2019|12|08}}
 
| latest release date = {{start date and age|2019|12|08}}
 
| programming language = C
 
| programming language = C

Latest revision as of 17:00, 13 December 2019

n1ghtshade
N1ghtshade.png
N1ghtshade-screenshot.png
n1ghtshade beta 2
Original author(s) synackuk
Developer(s) synackuk
Initial release beta 1 / 7 Dec 2019; 2 months ago
Stable release beta 9 / 8 Dec 2019; 2 months ago
Development status Active
Written in C
Operating system macOS
Available in English
Type Jailbreaking / Downgrading

n1ghtshade is a downgrading and jailbreaking utility. It utilises the checkm8 exploit and is compatible with devices that use the A6 processor, such as the iPhone 5.

The tool is capable of tethered jailbreaking iOS 6 and 7 and tethered downgrading to any iOS version supported by the device. It is only compatible with macOS Mojave as of beta 2.

n1ghtshade's source code is available on GitHub under the GNU GPL v3 licence.

Version History

Version Release Date Download Changes
beta 1 7 Dec 2019 GitHub
  • Initial release.
beta 2 GitHub
  • Fixed bug in idevice finding code
beta 3 GitHub
  • Attempt to fix some of the libusb issues
beta 4 GitHub
  • Fixed a really dumb bug.
beta 5 GitHub
  • Fixed "failed to upload iBEC"
beta 6 8 Dec 2019 GitHub
  • Fixed reliability issues, NOTE that if you're on Catalina you must eject the iPhone from finder before you run n1ghtshade.
beta 7 GitHub
  • Fixed iPhone5,1 support
beta 8 GitHub
  • Attempted A6X support
beta 9 GitHub
  • Now works on macOS Sierra and up, Working A6X support.